There has been dissussion recently around how reset binds should be handled in two separate areas, what exactly is resettable, and and the actual binds themselves. The first I think is a discussion for another time, but the second is much more concrete.
Currently, momentum has 3 separate bindable teleport commands,
mom_saveloc_current. The behavior of these three is mostly exactly what the command says, restart will restart the map, stage will bring you to the last stage start zone you were in assuming one exists, and saveloc_current brings you to your last active saveloc. There is some subtlety I am leaving out but that is outside of the current scope.
The problem with this current setup as I see it is that we simultaneously have too many commands and not enough commands. We don't have enough because if you are playing a bonus or a mode without "stages" like rj, there isn't a clear correct command that does exactly what you are looking for. There are too many commands firstly because restart_stage and saveloc_current actually do the exact same thing, just in separate and non-overlapping contexts.
What I would propose is to rescope and rename restart_stage as a generalized "last resettable location", which would bring it more inline with the behavior of sm_tp and sm_stuck that people are already used to from servers, and also would work as saveloc_current so people who prefer to have a dedicated bind don't need to use an swap alias with there current reset button or bind an extra button.
There was also talk about reverting the change to restart_stage to also restart map on maps with no stages game#1579, I think it makes sense to keep the functionality as is as i pointed out there.